Results 1 to 6 of 6

Thread: DoS Attack Fixer Linux Error

  1. #1
    JaySingh's Avatar



    Join Date
    Feb 17, 2010
    Last Online
    Oct 02, 2011
    Posts
    50
    Threads
    17



    DoS Attack Fixer Linux Error


    Greetings,

    I have a couple questions in regards to both the DoS attack fixer and linux TF2 servers in general, but I'll start with the DoS attack fixer first.

    When I first installed the DoS attack fixer on my windows box, I had everything running smoothly. Now that I switched to CentOS 4.8, I'm having a couple problems.

    I installed the DoS attack fixer into my addons folder, and I edited the vdf file to point towards the ".so" file.

    Code:
    "Plugin"
    {
            "file"  "../tf/addons/daf/bin/dosattackfix_i486.so"
    }
    This is what the error states when I start up my server.



    Is there a fix?

    EDIT: I'd just like to state that in the screen shot I posted, it shows it as:

    "..\tf\addons\daf\bin\dosattackfix_i486.so"

    But if I were to put the slashes the other way, like posted in the vdf file, the outcome still remains the same.

    EDIT #2: I'd just like to ask in regards to the "TF2 servers in general statement I mentioned". How is it that you have your servers increased to 33 slots? What I also realized is that it displays your servers as 32 slots via gameME stats.

  2. #2
    Drunken F00l's Avatar



    Join Date
    Dec 11, 2004
    Last Online
    Jun 11, 2019
    Posts
    5,874
    Threads
    182
    Reputation
    SourceOP Thread


        
    Steam: 76561197968459473 
    Steam join date: Dec 31, 1969
    Steam Level: 46
    Profile Status: Public



    Fix is in the error message. You need glibc 2.5 or later.

    The player limit remover plugin enables 33 player servers. Also, starting the server as a 32 player server with sourcetv enabled and then kicking the sourcetv bot produces the same effect.

  3. #3
    JaySingh's Avatar



    Join Date
    Feb 17, 2010
    Last Online
    Oct 02, 2011
    Posts
    50
    Threads
    17




    Quote Originally Posted by Drunken_F00l
    Fix is in the error message. You need glibc 2.5 or later.

    The player limit remover plugin enables 33 player servers. Also, starting the server as a 32 player server with sourcetv enabled and then kicking the sourcetv bot produces the same effect.
    Even when I do tf_enable 1, there is no bot in the server. I understand that I have to make an autoexec.cfg, but what should I put in it?

    And I got the DoS attack fixer working.

    Thank you

  4. #4
    Drunken F00l's Avatar



    Join Date
    Dec 11, 2004
    Last Online
    Jun 11, 2019
    Posts
    5,874
    Threads
    182
    Reputation
    SourceOP Thread


        
    Steam: 76561197968459473 
    Steam join date: Dec 31, 1969
    Steam Level: 46
    Profile Status: Public



    If you make autoexec.cfg, put tf_enable 1 in it. Or download this:
    http://www.sourceop.com/modules.php?...download&cid=4

    That plugin will let you just specify maxplayers 33.

  5. #5
    jj77's Avatar



    Join Date
    Feb 28, 2010
    Last Online
    Mar 01, 2010
    Posts
    12
    Threads
    1




    Wow shitheads are still DoS attacking servers ffs.I remember that way back in the TFC days

  6. #6
    jj77's Avatar



    Join Date
    Feb 28, 2010
    Last Online
    Mar 01, 2010
    Posts
    12
    Threads
    1




    Quote Originally Posted by jj77
    Wow shitheads are still DoS attacking servers ffs.I remember that way back in the TFC days
    On a side note TF2 MB's sure are dead compared to the old days of TFC - WON - early steam.Rofl people can't even reply to help threads with a simple no , yes , or a clear answer for the most part roflz gg

Tags for this Thread