PDA

View Full Version : SourceOP on FF?



theob5
Sep 16, 2007, 08:56 PM
I added SourceOP to my Fortress Forever Dedicated Server, but it doesn't seem to be loading up...
Is it that SourceOP isn't compatible with FF yet (or at least to the Public)? Sorry if I'm asking a dumb question or if there's an obvious answer, but I've tried adding SourceOP to my server several different ways and it still doesn't load up.

Thanks for the help.


EDIT: I also tried putting it on my Day of Defeat: Source server, but that doesn't seem to be working either (I used program that automatically adds Sourceop and clicked Day of Defeat Source when it asked me what game and it still doesn't work.

Drunken F00l
Sep 16, 2007, 09:16 PM
Are you using srcds?

SourceOP is compatible with FF. You will need a seperate srcds installation with FF on that. Then install SourceOP to C:\srcds\FortressForever (or wherever you installed srcds).
By clicking the DODs option in the installer, you are installing it as a listen server. If you want to use the dedicated server steam tool, you will have to selected the dedicated server option.

theob5
Sep 16, 2007, 09:22 PM
OK, I'll look into all that. That's probably the problem with my FF server though.
Thanks a lot. :)

Drunken F00l
Sep 16, 2007, 09:34 PM
No problem. Let me know how it works out.

theob5
Sep 16, 2007, 09:45 PM
It was going well until I realized that I don't have srcds.exe for some reason (I was actually at the end of creating the server when I actually needed it then).
Is there any reason as to why I don't?

Drunken F00l
Sep 16, 2007, 09:47 PM
You have to install it seperately. See http://www.srcds.com/db/engine.php?subaction=showfull&id=1097362093 for more info.

theob5
Sep 16, 2007, 09:49 PM
That's the guide I've been following the whole time and it's been going great up until the last step where I actually run srcds and it cant find the exe.

Drunken F00l
Sep 16, 2007, 09:53 PM
What exactly are you doing to get that error and what exactly is the error?

theob5
Sep 16, 2007, 09:56 PM
Alright, well I'm at the part where I enter into Start, Run, "c:\srcds\srcds.exe -console -game FortressForever +map ff_well -maxplayers 16 -autoupdate"
If you're not sure what I'm talking about, it's nearing the end of that guide.
Now, when I hit Enter, it says that Windows cannot find c:\srcds\srcds.exe

Drunken F00l
Sep 16, 2007, 10:01 PM
Then that isnt where you installed srcds.exe. When u got hldsupdatetool where did you put it.

theob5
Sep 16, 2007, 10:04 PM
I ran it and when it talked about the destination folder, I put c:\srcds
Then I ran cmd and did the whole

C:
cd \srcds
hldsupdatetool

Drunken F00l
Sep 16, 2007, 10:24 PM
Do start->run and just type C:\srcds. What's in that folder? Anything at all?

theob5
Sep 16, 2007, 10:27 PM
yes:

appdir.txt
HldsUpdateTool_20.mst
Install.txt
ClientRegistry.blob
hldsupdatetool_readme.txt
UNWISE
Hldsupdatetool
FortressForever folder
bin with sourceop dll in it

Drunken F00l
Sep 16, 2007, 11:08 PM
So everything that is srcds is missing. You must have skipped step 2 or did it incorrectly.

theob5
Sep 17, 2007, 02:31 PM
I keep repeating all the steps exactly as they put it in the guide, but for some reason, I'm always missing the srcds.exe

Drunken F00l
Sep 17, 2007, 03:23 PM
When you run hldsupdatetool, pay attention to what the output is.

theob5
Sep 17, 2007, 03:53 PM
The output is always the srcds and in fact, I just deleted my srcds folder and started from scratch.
I ran the updated to c:/srcds and the exe STILL doesn't come up.

Drunken F00l
Sep 17, 2007, 03:58 PM
That's because when you run hldsupdatetool, you are doing something wrong.

When at the command line, run:
hldsupdatetool -command update -game hl2mp -dir C:\srcds

Pay close attention to the output of that program. If it says Checking bootstrapper version and then says updating to version 20 (which it will the first time that you run it), you will have to run the above command again.

theob5
Sep 17, 2007, 04:05 PM
are you sure I enter hl2mp? I'm making a Fortress Forever server.

Drunken F00l
Sep 17, 2007, 04:10 PM
Yes. You have to install FortressForever on top of the srcds base. Installing hl2mp will give you that base.

theob5
Sep 17, 2007, 04:15 PM
OK, so it's in the middle of installing all that in my command prompt (sorry for all the trouble by the way).
After that's finished, where do I resume following the normal guide?

Drunken F00l
Sep 17, 2007, 04:24 PM
OK, after it's done installing, type
HldsUpdateTool.exe -command version and make sure it lists at least Source Dedicated Server, Base Source Shared Materials, Base Source Shared Models, Base Source Shared Sounds. If it does, you can then put back the FortressForever folder into the srcds folder. After that, you are ready for the third step. To start the fortress forever server type:

c:\srcds\srcds.exe -console -game FortressForever +map ff_cornfield -maxplayers 16 -autoupdate

The server should then start. You can shut it down and then install SourceOP if you want. You would use the installer (advanced mode) and install it to C:\srcds\FortressForever

theob5
Sep 17, 2007, 04:26 PM
ok. It's still installing (at 14.86 %, so it's gonna take a while). I'll tell you how it goes if the server is successfully put up with sourceOP and all.

Drunken F00l
Sep 17, 2007, 04:28 PM
OK. Don't forget after this is done, you still have to install the FortressForever server and then install SourceOP before it will work.

theob5
Sep 17, 2007, 05:09 PM
but you see, I STILL don't have the exe. And either way, when I type
c:\srcds\srcds.exe -console -game FortressForever +map ff_cornfield -maxplayers 16 -autoupdate, it says it isn't recognized as an internal or external command.

Drunken F00l
Sep 17, 2007, 08:19 PM
Then the update didn't finish or something. Run the hldsupdatetool command again (you don't have to delete anythong or start over, you're fine just run it again).

theob5
Sep 17, 2007, 08:22 PM
I keep doing that but that exe still never shows up. I don't get it...

Drunken F00l
Sep 17, 2007, 09:46 PM
Well when you run hldsupdatetool now, what does it say? You can copy and paste from the command window. To do this, you can right click the command window, select mark, select the text, and press enter. Then paste it here using Ctrl+V.

theob5
Sep 18, 2007, 03:48 PM
ok, so when I type hldsupdate tool in command prompt that's directed towards the srcds folder, this is what comes up:


C:\srcds>hldsupdatetool
Checking bootstrapper version ...

Use: hldsupdatetool -command <command> [parameters] [flags]

Commands:

update: Install or update HLDS

parameters:
-game <game> - Game name: use 'list' to see available games
-dir <installdir> - HLDS Install dir
(if dir not specified, will use value from last run of tool)

flags:
-verify_all - Verify all HLDS files are up to date
-retry - Automatically retry every 30 seconds if the St
eam Network is busy
-remember_password - Remember password (if a username is supplied)

For example: hldsupdatetool -command update -game cstrike -dir c:\hlds

version: View installed versions

list: View available games

Optional parameters for all commands:

-username <username> - Steam account username (only needed to access
limited content)
-password <password> - Steam account password (only needed to access limited content)

Drunken F00l
Sep 18, 2007, 07:37 PM
That's good. But I meant what comes up when you type:

hldsupdatetool -command update -game hl2mp -dir C:\srcds

theob5
Sep 18, 2007, 08:17 PM
A very long list of things I am downloading (models, textures, stuff like that) comes up with percentage numbers next to it.
At the end, though, this is what it says:


42.67% C:\srcds\hl2\models\vortigaunt_postures.ani
42.67% C:\srcds\hl2\models\vortigaunt_postures.mdl
42.68% C:\srcds\hl2\models\vortigaunt_slave.dx90.vtx
42.71% C:\srcds\hl2\models\vortigaunt_slave.mdl
42.73% C:\srcds\hl2\models\vortigaunt_slave.phy
42.75% C:\srcds\hl2\models\vortigaunt_slave.vvd

Checking/Installing 'Base Source Shared Sounds' version 4

Connection Reset, WinSock Error 10054 "Connection reset by peer"

Drunken F00l
Sep 18, 2007, 11:32 PM
Connection Reset, WinSock Error 10054 "Connection reset by peer"

That means there was an error part way through and that you have to try again. You aren't done until it says:

HLDS installation up to date

theob5
Sep 19, 2007, 06:02 AM
OK, I finished it and finally have the .exe in my srcds folder!! When I execute srcds, though, a bunch of errors come up in the prompt and THEN it finally starts (with all the errors before it).
Plus SourceOP doesn't load, even though I added it to Fortress Forever in the srcds folder.