PDA

View Full Version : SourceOP Linux Problems



Flc
Oct 22, 2010, 12:29 PM
Hey,

we (flc) have a problem to get SourceOP running on our Linux Server.
SourceOP just doesn't want to load :S We see this in the logs: Unable to load plugin "../bin/sourceop".

You probably know that the game is updated to the engine 2009. Well there is a problem. It was ok before the update.

OS: Linux Fedora

We also contacted the host for the problem, but thay say it is a sourceOP problem and not the server.

We hope you can help us. Thx

Drunken F00l
Oct 22, 2010, 04:48 PM
Can you check for libssl.so.6 as mentioned in these threads:
http://www.sourceop.com/modules.php?name=Forums&file=viewtopic&t=3810
http://www.sourceop.com/modules.php?name=Forums&file=viewtopic&t=4602

Also check here:
http://www.sourceop.com/wiki/Installing#Troubleshooting_Linux_Installation

FrozenHaxor
Dec 11, 2010, 08:40 AM
Hey Drunken F00l,

Would you mind compiling for me a linux version for TF2 that uses libssl.so.0.9.8 instead of libssl.so.6? My host refused to do symlink saying "We won't be symlinking to random versions, do it local". I even tried to use hex editor to change that, but it was just crashing my server on startup... I really want to use SourceOP on TF2 as I enjoyed it on old CS:S, I also saw on this forum someone else that had trouble with version of libssl.so.0.9.8, so maybe it will help more people and not just me.


I'm really looking forward it!
Love you forever if you do that :gg:

Drunken F00l
Dec 12, 2010, 04:28 PM
You could probably do it local. Copy libssl.so.0.9.8 to orangebox\bin\libssl.so.6.

FrozenHaxor
Dec 13, 2010, 01:44 AM
Thank you, I'll try this when I get back to home :).

FrozenHaxor
Dec 14, 2010, 08:07 AM
Thanks alot, it worked! :D